OAuth
Authorisation for partner apps (RFC 6749, RFC 7636, RFC 7009).
Start authorisation
Where a partner app sends the dealer to connect it (RFC 6749 4.1.1,
Exchange a code or refresh token
RFC 6749 4.1.3 and 6. Authenticate the client with HTTP Basic
Revoke a token
RFC 7009. Revokes an access token (`vh_oat_`) or a refresh token